4K/UHD Video ruckelt

Wer wie ich unter ruckeln bei 4K bzw. eigentlich Ultra HD (UHD) Inhalten leidet kann diverse Probleme haben.

In meinem Fall wollte ich Videos von meinem einigermaßen leistungsstarkem QNAP TS853A-8G UHD Videos im Browser auf dem PC abspielen. Auch beim Abspielen mit TV-Geräten fiel das aber auf. Eigentlich gibt es meiner Meinung nach nur zwei oder drei Fragen zu stellen um die Ursache herauszufinden:

  1. Ist mein Gerät verkabelt oder per WLAN verbunden?
    So schön WLAN auch ist, so schrecklich ist es auch. Fluch und Segen zugleich. Mit dem neuen ac mag das besser laufen, darunter ist die Bandbreite ggf. zu gering. Abgesehen davon stören diverse andere Signale das WLAN-Signal.
  2. Ist meine Hardware performant genug?
    Ich kenne offiziell keinen mindestens vorausgesetzten Prozessor, aber alles unter 4 Kerne mit mindestens 1,6 GHz dürfte wenig bis gar nicht vernünftig laufen. Zum Vergleich, mein QNAP hat einen 4 Kerner mit 1,6 GHz bzw. 2,08 GHz Boost.
  3. Ist das abzuspielende Video im HEVC Format? (Auch H.265 oder x265)?
    Der seit 2012 entwickelte Standard der erst seit 2016 stark im Kommen ist bereitet unter diversen Playern noch Probleme. HEVC ist ein Standard zur Kompression von Videos, x265 ist dabei die Open Source Variante. Plex wie Kodi und einige andere Player haben Probleme mit diesem Standard welches sich in ruckeln, dauernden längeren Pausen äußern kann.

    1. Wenn das Video HEVC ist, ist die Hardware HEVC fähig?

Oft ist das Problem 3.1, denn lediglich die neuesten Prozessorgenerationen haben es hardwareseitig im Prozessor integriert, darunter z.B. Intels Kaby Lake Prozessoren. Denn ein HEVC Video in einem nicht HEVC fähigem Prozessor führt zu Problemen und eben diesen genannten Problemen. Oft hilft es, nicht HEVC Versionen, also den x264 Standard zu verwenden.

Probleme bei der Deinstallation, Installation oder Upgrade von Plex Media Server (PMS) – Can’t uninstall old Plex Media Server

Hallo,

heute muss ich mal wieder etwas Teilen, was vielleicht dem einen oder anderen helfen kann. Dieses Phänomen taucht nun zum zweiten Mal auf meinem Windows PC auf, das letzte mal fand ich keine Lösung und musste Windows neuinstallieren. Es geht um die Installation, das Upgraden oder Deinstallieren von Plex Media Server (PMS) auf einem Windows PC. Eine ältere Version 0.9.16.04 wurde vor wenigen Tagen auf 0.9.16.06 aktualisiert. Seit jeher macht mir der PMS Probleme. Er lädt keine Agenten mehr, Servereinstellungen sind nicht verfügbar, er lädt keine Metadaten zu Serien und Filmen, etc. Eine Neuinstallation musste her, sogleich den Installer heruntergeladen, ausgeführt. Prompt das erste Problem: Der alte PMS lies sich offenbar nicht deinstallierten, plus man erhält die Nachricht über ein MSI-Package im Ordner Package Cache welches fehlt. Angeblich eine Netzwerkressource. Der Pfad verweißt auf …\Program Cache\{XXXX-XXXX-….\0.9.16.4\pms.msi oder ähnliches. Der Ordner ist allerdings nicht vorhanden, ebenso wenig wie die pms.msi.

Aber keine Sorge, es gibt Hilfe und wohl eine Lösung, die zumindest bei mir und vielen weiteren Personen zu klappen scheint. Hier erklärt:

  1. Die Version aus dem PMS-Archiv herunterladen, auf welche dieser Dialog in der Fehlermeldung zeigt. Bei mir 0.9.16.4. Hinweis: Diese Version wird als 0.9.16.04 im Archiv gelistet!
  2. WiX Toolset in dieser oder einen neueren Version herunterladen, von hier: http://wix.codeplex.com/releases/view/617257
  3. Die heruntergeladene Datei vom WiX Toolset, z.B. wix310.exe ausführen und installieren. Bei 64-bit Systemen landet es im Verzeichnis C:\Program Files (x86)\WiX Toolset v3.10\
  4. Öffnet die Windows-Eingabeaufforderung (z.B. über Windowstaste + R → cmd → Enter)
  5. Navigiert zum Ort, an dem sich die heruntergeladene alte Plex Media Server Installation befindet, z.B. mit
    cd %UserProfile%\Downloads, so landet ihr in eurem Download-Ordner von Windows.
  6. Nun tippt folgendes ein oder fügt es ein (Einfügen funktioniert nicht mit Strg + V aber mit Alt+Space danach B danach E):
    “C:\Program Files (x86)\WiX Toolset v3.10\bin\dark.exe” Plex-Media-Server-Plex-Media-Server-0.9.1604.1911-ee6e505-en-US.exe -x PMS
    Ggf. Program Files (x86) durch Program Files ersetzen, WiX Toolset v3.10 anpassen je nach Version ebenso die Installationsdatei vom PMS anpassen je nach Version. Mit Anführungszeichen in die Eingabeaufforderung eingeben!
  7. Wenn ihr nun Enter drückt wird in dem Verzeichnis an dem sich die PMS Installation befindet, ein Ordner namens PMS erstellt. In diesem findet ihr zwei Ordner, einer davon heißt AttachedContainer und in diesem wiederum findet ihr die pms.msi.
  8. Wenn ihr nun die Installation des eigentlichen PMS startet und im Dialogfenster von zuvor nach dem Ort der pms.msi gefragt werdet, könnt ihr mit Durchsuchen bzw. Browse den Pfad zu eurer extrahierten pms.msi angeben.
  9. Et voilá, es sollte laufen 🙂

Ich hoffe der Tipp ist für den Einen oder Anderen hilfreich.